Author Archives: joeldart

About joeldart

I am a 29 year old software developer living in Indianapolis, IN.

the siren call of starting fresh

Technical debt is hard to measure and estimate. There are code quality metrics you can include. You can measure how long it takes you to implement new features. You can measure how long it takes you to land bug fixes. … Continue reading

Posted in dev, Uncategorized | 1 Comment

a few weeks ago

3/23/2015. Tonight, like every night, I put down my daughter, waited till I knew the last escape attempt had been foiled, and go retrieve my infant son from mommy. Kathryn breaks his latch and waits awkwardly while I position myself … Continue reading

Posted in Uncategorized | Leave a comment

next door – part 2

Since putting up the fence it’s simply inconvenient to gather trash in the alley. This trip I put in my trash bag an empty pack of newports, a high top sneaker with $100 bills painted on, a beer bottle, and … Continue reading

Posted in Uncategorized | Leave a comment

next door – part 1

“All my liiife,” the sisters crooned, “I prayed for someone like you.” We were stopped in the alley outside our house. Fenwick, our dog, patiently stood around. Originally, the girls had planned to pet him. “Hiya, Foowick!” He was a … Continue reading

Posted in Uncategorized | Leave a comment

Don’t Be a Hater 2013

Editor’s note: I’m calling time on this one. Have to publish as-is or it will rot in drafts forever 2 years is enough. Each year my friends and I go over some personal goals we would like to take on … Continue reading

Posted in Uncategorized | Leave a comment

November Bunkerjs

We’ve been doing an internal JavaScript meetup once a month and there are so many great resources coming out of it, I though I’d reblog for others to see. Hope you enjoy. -Joel It was great to see new faces at … Continue reading

Posted in Uncategorized | Leave a comment

Upgrading npm on windows

Had a windows machine which needed to upgrade npm to avoid the whole ^ incompatibility issue. ex: npm ERR! Error: No compatible version found: minimist@’^0.1.0′ npm ERR! Valid install targets: npm ERR! [“0.0.0″,”0.0.1″,”0.0.2″,”0.0.3″,”0.0.4″,”0.0.5″,”0.0.6″,”0.0.7”,”0.0.8 “,”0.0.9″,”0.0.10″,”0.1.0″,”0.2.0″,”1.0.0″,”1.1.0”] Well, I was doing it in … Continue reading

Posted in Uncategorized | Leave a comment